Verification is currently underway for the maintenance items.
Posted Aug 29, 2025 - 15:38 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 29, 2025 - 15:30 CDT
Scheduled
For customers who host their website with mojoPOS, we will be making updates to the "live" menu widget. While we do not anticipate any down time, it may be possible that the menu widget on your website will be temporarily unavailable.
Posted Aug 29, 2025 - 15:24 CDT
This scheduled maintenance affected: mojoPOS Website Hosting (Live Menu Widget).