Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 30, 2025 - 23:00 CDT
Scheduled
We will be executing maintenance which may make the delivery and processing of SMS/Text messaging unreliable to you and your customers. The remainder of the system will be not be impacted.
Posted Mar 27, 2025 - 17:17 CDT
This scheduled maintenance affected: Twilio SMS Long Code, North America, Twilio SMS Long Code, North America, Twilio SMS, Twilio SMS and mojoPOS (Curbside Check-In/Alert, Online Order Status Text Alerts, Walk-Up Order Status Text Alerts).